The connectivity issue between DrChrono and Availity has been resolved. Eligibility checks within the platform are now functioning as expected.
We appreciate your patience while we worked to address this issue. If you continue to experience any problems, please reach out to our Support Team for further assistance.
Thank you for your continued trust in DrChrono.
Posted Jul 01, 2025 - 17:35 PDT
Update
DrChrono is currently experiencing connectivity issues with Availity, which is affecting eligibility check functionality within the platform. Our team is working with Availity to resolve the issue and restore normal service as quickly as possible.
We will provide further updates as more information becomes available. Thank you for your patience.
Posted Jul 01, 2025 - 13:44 PDT
Identified
We want to make you aware that Availity is currently experiencing technical issues on their platform, which is affecting the ability to run eligibility checks within DrChrono.
Our team has contacted Availity for assistance and is closely monitoring the situation. We will share updates as soon as more information becomes available.
Thank you for your patience and understanding.
Posted Jul 01, 2025 - 06:11 PDT
This incident affected: 3rd party services (E-Provider Solutions).