DrChrono System Issues

Incident Report for DrChrono

Resolved

The system remains operational, and we have not observed any further issues since moving to monitoring yesterday. This incident has been resolved. Our Engineering team will continue to review the event as part of our ongoing efforts to maintain the reliability and performance of the platform. Thank you for your patience,
Posted Jul 08, 2026 - 13:29 PDT

Update

The system remains operational, and our Engineering team continues to monitor the platform. We will provide updates on this page as more information becomes available.
Posted Jul 08, 2026 - 07:04 PDT

Monitoring

Our Engineering team has implemented mitigation measures and is continuing to monitor the system. We will provide updates on this page as they become available.
Posted Jul 07, 2026 - 12:55 PDT

Update

We are continuing to investigate the issue impacting DrChrono. Our Engineering team is actively working to resolve the issue. We will provide updates on this page as they become available.
Posted Jul 07, 2026 - 11:30 PDT

Investigating

We are currently aware of system issues impacting DrChrono and are actively working with our Engineering team to investigate and resolve the issue. We will continue to update this page.
Posted Jul 07, 2026 - 09:59 PDT
This incident affected: drchrono.com.